Blog
DB2utor

Categories

February 17, 2009

Call for Requirements: IBM Java SDK for z/OS

IBM would like to hear from you regarding your organization's use of Java stored procedures. Before you can answer these questions, you'll need to know if you have the IBM SDK for z/OS Java 2 installed on all of your z/OS systems. If you have Java stored procedures, then you have it. If you're not sure, ask your systems programmer--or run this query, which will return a list of Java stored procedures:

SELECT SCHEMA, NAME, CREATEDBY
     , LANGUAGE, ROUTINETYPE
     , SPECIFICNAME, WLM_ENVIRONMENT
FROM SYSIBM.SYSROUTINES
WHERE LANGUAGE = 'JAVA';

Here are the questions:

  • If YES (the SDK is installed), what level(s) of the SDK are installed?
  • If NO (the SDK is NOT installed), do you foresee any problems installing the SDK as a prerequisite for a DB2 for z/OS tool product?
  • Do you have zAAPs on the LPARs you would run the tools on?
  • Any comments about our using Java on z/OS?


Your feedback will help drive IBM's future directions in DB2 for z/OS tools development. Please send your feedback directly to Bryan Smith: bfsmith@us.ibm.com .